المساعد الشخصي الرقمي

مشاهدة النسخة كاملة : مشكلة خظأ فى wpscan على نظام أوبنتو 12.04


Ahmed Ethic
10-05-2013, 10:22 AM
السلام عليكم

مشكلة خظأ فى wpscan على نظام أوبنتو 12.04
صور مشكلة :
[فقط الاعضاء المسجلين هم من يمكنهم رؤية الروابط]


كلام خظأ

:/opt/wpscan# ./wpscan.rb
./wpscan.rb:175: odd number list for Hash
show_progression: true,
^
./wpscan.rb:175: syntax error, unexpected ':', expecting '}'
show_progression: true,
^
./wpscan.rb:175: Can't assign to true
./wpscan.rb:176: syntax error, unexpected ':', expecting '='
exclude_content: wpscan_options.exclude_content_based
^
./wpscan.rb:177: syntax error, unexpected '}', expecting kEND
./wpscan.rb:212: syntax error, unexpected ':', expecting ')'
file: wpscan_options.enumerate_all_...
^
./wpscan.rb:212: syntax error, unexpected ',', expecting kEND
./wpscan.rb:214: syntax error, unexpected ')', expecting kEND
./wpscan.rb:234: syntax error, unexpected ':', expecting ')'
file: wpscan_options.enumerate_all_...
^
./wpscan.rb:234: syntax error, unexpected ',', expecting kEND
./wpscan.rb:236: syntax error, unexpected ')', expecting kEND
./wpscan.rb:255: syntax error, unexpected ':', expecting ')'
file: DATA_DIR + '/timthumbs.txt',
^
./wpscan.rb:255: syntax error, unexpected ',', expecting kEND
./wpscan.rb:257: syntax error, unexpected ')', expecting kEND
./wpscan.rb:280: syntax error, unexpected ':', expecting ')'
range: wpscan_options.enumerate_user****s_range,
^
./wpscan.rb:281: syntax error, unexpected ':', expecting '='
show_progression: false
^
./wpscan.rb:295: syntax error, unexpected ':', expecting ')'
wp_users.output(margin_left: ' ' * 4)
^
./wpscan.rb:295: syntax error, unexpected ')', expecting kEND
./wpscan.rb:300: syntax error, unexpected ':', expecting ')'
...User.new(wp_target.uri, login: wpscan_options.user****)
^
./wpscan.rb:300: syntax error, unexpected ')', expecting kEND
./wpscan.rb:323: syntax error, unexpected ':', expecting ')'
show_progression: true,
^
./wpscan.rb:323: Can't assign to true
./wpscan.rb:324: syntax error, unexpected ':', expecting '='
verbose: wpscan_options.verbose
^
./wpscan.rb:325: syntax error, unexpected ')', expecting kEND
./wpscan.rb:328: syntax error, unexpected ':', expecting ')'
wp_users.output(show_password: true, margin_left: ' ' * 2)
^
./wpscan.rb:328: Can't assign to true
wp_users.output(show_password: true, margin_left: ' ' * 2)
^
./wpscan.rb:328: syntax error, unexpected ':', expecting '='
wp_users.output(show_password: true, margin_left: ' ' * 2)
^
./wpscan.rb:328: syntax error, unexpected ')', expecting kEND
./wpscan.rb:342: syntax error, unexpected kRESCUE, expecting kEND
rescue SystemExit, Interrupt
^
./wpscan.rb:342: dynamic constant assignment
rescue SystemExit, Interrupt
^
./wpscan.rb:342: dynamic constant assignment
./wpscan.rb:342: syntax error, unexpected '\n', expecting '='
./wpscan.rb:344: syntax error, unexpected kRESCUE, expecting kEND
rescue => e
^
./wpscan.rb:356: syntax error, unexpected $end, expecting kEND

Ahmed Ethic
10-06-2013, 02:02 PM
خلاص تم حليت مشكلة :ok:

مشكلة هى ruby فقط

wpscan ده تحتاج نسخة 1.9 ruby مش نسخة 1.8

نسخة 1.8 ruby لاتشغيل مع wpscan هى سبب مشكلة

معرفة نسخة ruby فى أوبنتو

أمر :
ruby -v

هاطلع معك كده :
ruby 1.9.3p0 (2011-10-30 revision 33570) [i686-linux]

اذا عندك نسخة 1.8 لازم تسمحو كله و حمل نسخة 1.9

صور شغال عادي مع نسخة 1.9 ruby :

[فقط الاعضاء المسجلين هم من يمكنهم رؤية الروابط]